Back to overview
Bulk Sign Notes Functionality
Mar 27 at 02:46pm EDT
Affected services
EMR
Resolved
Mar 27 at 02:46pm EDT
We've identified a critical issue with the Bulk Sign Notes functionality. As a precaution, we've temporarily disabled the Bulk Sign Notes feature to avoid any further issues as we work on a permanent solution. We understand the inconvenience this may cause and sincerely appreciate your patience and cooperation as we work to resolve this matter.
Resolved on April 2, 2024.
Affected services
EMR